Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I believe I have a data corruption issue on my server.

This server has been hitting performance issues over the past few days with a specific set of software: gallery2. I've been attempting to fix it through the normal paths, one of which is deleting the software's caches. The script provided to do so crashes mysql when I run it. The deletion of the cache seems to hang on a specific folder, so I tried to chmod it.

Attempting to chmod the directory crashes mysql as well and the terminal reports the following after the crash:

chmod: changing permissions of `entity/1/4/145446.inc': Read-only file system + one of these lines for every file in the directory

The directory in question is: /var/www/vhosts/autoimagery.com/httpdocs/gallery2data/cache/entity

The command I ran is a simple recursive chmod: chmod -R 777 entity/

I'm completely lost on how to resolve this.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The message "read-only filesystem" would indicate some structural issue (i.e. disk, or filesystem corruption) in the underlying filesystem being used. My suggestion would be to take the system to single user mode, and do a FULL fsck on the disk area.

If this is the root filesystem, you can invoke a full fsck by 'touch /forcefsck' on redhat linux varients (Redhat, Centos, Fedora). Then doing a reboot.

share|improve this answer
    
Hey, thanks for your answer. I just read up on single user mode: centos.org/docs/5/html/Installation_Guide-en-US/… This is a dedicated machine I have at a remote host. Is this something I have the ability to do via SSH? –  robr Sep 13 '11 at 20:43
    
Hey, my host put the server on what they call 'rescuelayer' and ran fsck immediately after my description of the problem. It fixed the issue completely. Thanks for your help! It's probably bad for karma to name the host but they were excellent so here goes: Softlayer. Support was stellar. –  robr Sep 14 '11 at 1:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.