Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed SQL Server Express 2005 with all available options. When I run Start->Programs->SQL Server 2005->Reporting Services Configuration I get an error immediatley:

"An unknown error has occurred in the WMI Provider. Error Code 8000000A"

I then cannot configure a reporting server. Any suggestions for how to fix this issue?

EDIT: I am running running this on a Windows XP machine, and I have installed SQL Server 2005 Version 9.1.2047.00, which I believe is SP 1.

share|improve this question
add comment

2 Answers 2

Have you installed SP2 or SP3 for SQL Server 2005? This is an issue with SP1 on Vista/2k8.

See: http://msdn.microsoft.com/en-us/library/ms156468.aspx

From the afore mentioned website (around halfway down):

Reporting Services SP1 and earlier do not run on Windows Vista. If you try to run an SP1 report server on Windows Vista, you will encounter: An unknown error has occurred in the WMI provider. Error Code 8000000A when using Reporting Services Configuration tool

NOTE: This quote has been modified from the original to narrow scope to your exact error.

share|improve this answer
add comment

As it turns out this error disappears when you do things with administrative access. I must have not had the right permissions. Too bad the error message couldn't be a little more informative.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.