Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 1.5GB LUN, on a QNAP NAS.

The LUN is attached to a W2K3, and has some folders shared on it.

On one sub-folder there is a specific file, that is corrupted. I need to delete it, but I can't even access it. The file is enter image description here

The error I get when trying to delete is (current user is the Domain Administrator) enter image description here

When I want to schedule a CHKDSK, it says it can't, as it needs to be done in reboot. but in Reboot, the LUNS are not yet attached. enter image description here

  • What else can I try please?

UPDATE: Issue solved. I ran CHKDSK from the command line (actually forgot it even exists). It done massive deletes and updated security ID's on 100k's of file. The trouble file has been deleted, and I assume ton's of others as well.


share|improve this question
You don't mention how this LUN is shared? FC, FCoE, iSCSI? – Chopper3 Sep 14 '11 at 8:50
Thanks, it's via ISCSI. – Saariko Sep 14 '11 at 8:57
This is now solved - I ran CHKDSK from the command line: CHKDSK /F – Saariko Sep 14 '11 at 8:59
This site is for PROFESSIONAL sysadmins, are you sure this is the right place for you? – Chopper3 Sep 14 '11 at 9:19
How would I become a professional if I will not ask? Learn? Try? At least I know how to ask the questions. Haven't you ever missed a command? Have a great sysday – Saariko Sep 14 '11 at 11:48

I ran CHKDSK from the command line: CHKDSK /F

*using windows to much, makes you forget command line functions.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.