Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to get sendmail to work with aws. Using this additional info as well as the amazon sendmail setup instructions I can successfully send mail from the command line.

When I try to send it through my app I get the following in my mail log and no mails are received.

Can anyone let me know what this means? I am not sure how to t/s the problem or where to go from here.

sendmail[20162]: starting daemon (8.14.4): SMTP+queueing@01:00:00
sm-msp-queue[20170]: starting daemon (8.14.4): queueing@01:00:00
sendmail[20174]: kVR020174: From:... List:; syntax illegal for recipient addresses
sendmail[20174]: kVR020174: Reply-To:... List:; syntax illegal for recipient addresses
sendmail[20174]: kVR020174: from=apache, size=150, class=0, nrcpts=1, msgid=<201109140952.kVR020174@ip-....ec2.internal>, relay=apache@localhost
sendmail[20175]: kK5020175: from=<apache@ip-....ec2.internal>, size=452, class=0, nrcpts=1, msgid=<201109140952.kVR020174@ip-....ec2.internal>, proto=ESMTP, daemon=MTA, relay=localhost [1$
sendmail[20174]: kVR020174: to='myemail@mydomain.com, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30150, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (kK5020$
sendmail[20174]: kVR020174: kVS020174: DSN: Reply-To:... List:; syntax illegal for recipient addresses
sendmail[20175]: kK7020175: from=<>, size=2130, class=0, nrcpts=1, msgid=<201109140952.kVS020174@ip-....ec2.internal>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1]
sendmail[20174]: kVS020174: to=apache, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31174, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (kK7020175 Message accepted for delivery)
sendmail[20179]: kK7020175: to=root, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=32360, dsn=2.0.0, stat=Sent
sendmail[20177]: kK5020175: to=<myemail@mydomain.comm>, ctladdr=<apache@ip-....ec2.internal> (48/48), delay=00:00:11, xdelay=00:00:11, mailer=aws-email, pri=120452, relay=mydomain.$
sendmail[20177]: kK5020175: p8E9qVK5020177: DSN: unknown mailer error 32
sendmail[20177]: qVK5020177: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31723, dsn=2.0.0, stat=Sent

EDIT ADDITIONAL INFO

sendmail.cf [per aws config] or sendmail.mc [per other config option]

Maws-email, P=/opt/aws/ses/ses-send-email.pl, F=mDFMuXn, U=mailuser, 
        S=EnvFromSMTP/HdrFromSMTP, R=EnvToSMTP, A=ses-send-email.pl -r -k /opt/aws
        /aws-credentials -e https://email.us-east-1.amazonaws.com   -f $f $u

Added mailuser

/etc/passwd

mailuser:*:12345:12345: mailuser:/no/where:/no/shell

/etc/group

mailuser:*:12345:
share|improve this question
    
I assume you did put your credentials in /opt/aws/aws-credentials? –  dtech Sep 14 '11 at 12:16
    
yes they are in there, like I said I can send from command line fine using those same credentials –  enfield Sep 14 '11 at 12:30
    
haven't completely given up on this yet but attempting to use postfix as an alternative at this point. –  enfield Sep 14 '11 at 21:42

3 Answers 3

The information can be found in the unkown mailer error 32 line. This means that something went wrong with the local mailer (defined on a M line in the sendmail configuration) and that the error is not in the range of known errors (64-78)

My guess is that you haven't properly set up the mail forwarding.

share|improve this answer
    
Thanks for the response. This is new ground for me (Sendmail). I am not sure if you familiar with Sendmail on AWS but I included the two links to the docs I used for setup. Following those to configure my server I am not sure what I am missing or how to t/s from there. Any tips on what to look for to verify mail fowarding? –  enfield Sep 14 '11 at 10:44
    
untill you post your sendmail.mc/sendmail.cf file (the relevant lines like Maws-email) there's nothing someone can do but guess –  dtech Sep 14 '11 at 10:47
    
Ok added in bottom of original question. –  enfield Sep 14 '11 at 10:57
up vote 0 down vote accepted

Well took a different road here. Using PostFix instead.

share|improve this answer

I know this thread is old but it might help someone who sees this error. You need to verify both your sender and recipient's e-mail address on Amazon SES if you are using non-production mode. Once this is verified, it is helpful if you put the verified address in sendmail-cf where you specify the path to the executable,

Maws-email, P=/opt/aws/ses/ses-send-email.pl, F=mDFMuXn, U=mailuser, 
S=EnvFromSMTP/HdrFromSMTP, R=EnvToSMTP, A=ses-send-email.pl -r -k /opt/aws
/aws-credentials -e https://email.us-east-1.amazonaws.com -f verified_email@example.com $u
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.