Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

EDIT UPDATE: for others seeing this thread. For me the issue was the scsi card itself for some reason. I replaced the Adaptec with an LSI and it works great now

Regardless of if I'm backing up the local server or a "disk-disk-tape" the speed writing to the tape drive is only around 350-500MB/min (not sec...min).

That's painfully slow.

Hardware:

IBM x3630 server - 12GB RAM, Windows 2008 R2

  • Here are the specs on the controller and drives:

    • 46M0916 (M5014 controller) supports up to 6 Gbps of performance throughput for each port at full duplex • 44W2234 (IBM 300GB 15K 6 Gbps SAS 3.5-inch Hot-Swap HDD) supports: o Drive to host SAS interface that supports up to 6 Gb/s burst rate o Drive media to buffer interface that supports sustained interface data transfers of up to 204 MB/s • 42D0767 2 TB 7.2K rpm 6 Gbps NL SAS 3.5-inch HS HDD) supports: o Drive to host interface that supports up to 6.0 Gb/s burst rate o Drive media to buffer interface that supports sustained interface data transfers of up to 150 MB/s average

  • SCSI Controller = Adaptec 29320LPE U320

  • Tape Drive = HP Ultrium LT04 drive SCSI inside Overland Storage Arcvault 12


Things I've done so far:

  • Updated the firmware
  • Worked with BackupExec support to increase buffers, etc.
  • Ran the HP Tape Tool software (results showed that the tape might be operating at u160 speed, and performance tests showed write speed around 9MB/sec

So, I'm at a loss. All of the hardware is decent and compatible. I'd love to just rip and replace but I'm also wanting to figure this out.

EDIT: also getting these errors on the HP Tape Tools:

The drive is experiencing polling (1.0 / sec. polling rate) on initiator ID 7. Polling can interrupt the normal operation of the drive, and significantly reduce performance.

Don't know what that means though.

share|improve this question
    
Whats your read-speed? –  CyberOptic Sep 14 '11 at 14:41
    
Cyber...just about the same...between 9 and 12MB/sec –  TheCleaner Sep 14 '11 at 18:56

5 Answers 5

up vote 3 down vote accepted

I had a problem like yours with LTO3 and the fix for me was to replace the SCSI cable. Just a thought.

share|improve this answer
    
+1 Probably the cable or related connectors. –  Chris S Sep 14 '11 at 19:03
    
UPDATE: It turns out I thought it was the cable but it wasn't. It was the adaptec scsi card itself. I had replaced the cable, thought it was fixed, and when it went to run the next time it started fast and then slowed again. Replacing the adaptec card with an LSI card made it jump up to 3,500MB/min...all is well. –  TheCleaner Oct 13 '11 at 21:55

LTO can have very bad speed if you do not feed it with data at the speed of the tape. If the tape buffer becomes empty, at first, LTO will put some gaps on the tape and wait a little bit for data, then if no data is received in time it will stop and rewind. The rewind operation will slow the tape bandwidth to a crawl. See Tape Performance Problems on Wikipedia

share|improve this answer
    
It's backing up the data from the local disk it is attached to. The specs for the local disk are in the question. Copying data from "partition to partition" on the local server operates at around 90-120MB/sec –  TheCleaner Sep 14 '11 at 18:58
    
Try to profile the Windows kernel with kernrate to see which driver is slow. –  Mircea Vutcovici Sep 14 '11 at 19:21

We had a problem like that a few years ago before switching to fibre channel. We used close to the same card, an Adaptec 39320. We'd get occasional SCSI errors and slow performance. Our tape drive, an Overland Storage NEO2000 LTO3, was only running at U160. After talking to a couple different techs, one of them said that he had seen in the past that it had an issue using the higher speed Adaptec card. I restarted the computer, got into the SCSI card's configuration and set the speed down to 160. All my problems went away.

It looks like your Arcvault came with an option of either 160 or 320, so check to see what it is.

Long story short - if your Arcvault is only running at 160, set the card at 160. Also, what @Jamiko mentioned, swap your SCSI cable. I've seen that cause problems as well.

share|improve this answer

I had found that with BackupExec, under the General options, if you have the compression type set to "Hardware [if available, otherwise software]", the job will run much slower.

Try changing that option to "Hardware [if available, otherwise none]".

share|improve this answer

I can remember that HP ships some Windows Tools (including a registry edit) to prevent Windows from polling the SCSI bus (btw: the SCSI hostadapter is usually ID 7)

Have a look at http://support.overlandstorage.com/jive/entry.jspa?externalID=6561&categoryID=442 for more information about that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.