Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The HTTP specification doesn't impose a specific size limit for posts. They will usually be limited by either the web server or the programming technology used to process the form submission.

How i can increase this size for websphere?

share|improve this question

migrated from stackoverflow.com Sep 15 '11 at 6:27

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

I would recommend to rather change this via the Administrative Console.

In V7 navigate to Servers -> Server Types -> Web servers -> <servername> -> Plug-in properties -> Request routing.

In V6 you find this at Servers -> Web Servers -> <servername> -> Plug-in properties -> Plug-in <serverclustername> Properties.

There, change the Maximum size of request content parameter to No Limit. This sets the PostSizeLimit parameter.

The advantage is that this should also persist across a new plug-in generation, and is less error-prone.

share|improve this answer

To change the size of post request you have to follow these steps :

  1. Open the WebSphere plug-in configuration file (plugin-cfg.xml) in the WAS_HOME/config/cells directory with a text editor.
  2. Locate the ServerCluster stanza with the following name: WebSphere_Portal__Cluster
  3. Associated with this entry, find the parameter PostSizeLimit.
  4. Change to a value in bytes (changing into a value to set a new limit or changing into "-1" to disables limit).
  5. Save the changes and close the file.
  6. Restart the application and portal servers.
share|improve this answer
    
Thanks that's worked....... –  dungeon Hunter Sep 15 '11 at 5:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.