Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This happened after i modified the pg_hba.conf file. It is currently set on trust but the server still asks for a password (even tho when clicking properties the password field is disabled ) . I treied restarting and now the damn thing wont start at all (the server that is; i have no postgres processes now). I also installed postgres 9.0 now and it works . But i would realy like to regain access to the old server. I have also tried a solution involving resetxlog -f but to no avail

Here is what else i tried :




E:\Program Files\PostgreSQL\8.4.8\bin>pg_ctl.exe start -N "postgresql-8.4.8" -D
"E:\Program Files\PostgreSQL\8.4.8\data" -w
waiting for server to start...2011-09-15 08:17:29 EEST LOG:  could not create fi
le "postmaster.opts": Permission denied
............................................................could not start serv
er

E:\Program Files\PostgreSQL\8.4.8\bin>pg_ctl.exe runservice -N "postgresql-8.4"
-D "E:\PostgreSQL\8.4.8\data" -w
pg_ctl: could not start service "postgresql-8.4": error code 1063
share|improve this question

migrated from stackoverflow.com Sep 15 '11 at 7:10

This question came from our site for professional and enthusiast programmers.

    
Does system user "postgres" (or whatever you use to run postgres) have write permission on directory "E:\PostgreSQL\8.4.8\data"? –  Vladimir Protasov Sep 15 '11 at 5:50
    
" postgresql-8.4.8" is wrong..the service name i used was " postgresql-8.4" –  Sammy Sep 15 '11 at 5:51
    
@vladimir...well it worked until i changed the conf file..all i did was to try and set authentification method to trust; i doubt the permissions suddenly changed just because i played with pg_hba.conf –  Sammy Sep 15 '11 at 5:52
    
Check out is another postgres instance is running. This error is possibly caused by another application, which opened the file "postmaster.opts". –  Vladimir Protasov Sep 15 '11 at 5:59
    
@vladimir i have no postgres.exe or pg_ctl.exe processes in task manager .... –  Sammy Sep 15 '11 at 6:58

1 Answer 1

While reviewing my pg_hba.conf file I noticed that there was an O at the beginning in stead of a #.

I learned two things from this:

  1. Always check for the most incredibly stupid mistakes first
  2. Don't throw your TV out the window unless you have money to buy another one
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.