Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I run IIS on Windows 2008 R2 Standart Edition & bind IIS on a public IP. At my desktop PC, I cannot open any non-asp files if my IP is local -ie 192.168.35.45-

I can open

I cannot open

I can open all these files if I use ktunnel/proxy

I can open all these files if I use real IP in TCP/IP settings on my desktop

As you guess all links are accessible from the internet

share|improve this question
    
Is this just on your computer? Does it only happen for a particular web browser? If your browser is IE have you done anything weird with security zones? –  Zoredache Sep 15 '11 at 7:50
    
Any computer which have local IP. Tested with IE & Chrome. –  Nime Cloud Sep 15 '11 at 7:54
add comment

1 Answer

Is there more than one website set up in IIS manager pointing at the same folder... each having different settings?

share|improve this answer
    
I use same folder for mysite.com & www.mysite.com & mysite.org & www.mysite.org. All of them listed as mysite.com in the sites tree-list. –  Nime Cloud Sep 15 '11 at 20:06
    
OK, then time to add more detail on what happens when you try to open the file. If you can add the 'Tracing' Role Service, and enable Failed Request Tracing for the site, then configure a rule to trace all content, you may be able to work out what module is preventing your access. Could be that the static file handler mapping works differently remotely because of something else configured; IIS doesn't usually behave this way, so it's additional complexity that's killing ya. –  TristanK Sep 16 '11 at 11:19
    
Chrome says: Error 324 (net::ERR_EMPTY_RESPONSE) I can't trace because there is no server response/code –  Nime Cloud Sep 16 '11 at 11:52
    
What do you think the problem could be? –  TristanK Sep 17 '11 at 9:13
    
I have no idea; it looks like the static module disabled for local access/IP for all sites. –  Nime Cloud Sep 19 '11 at 5:49
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.