Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently got a box on prgmr. Excited, I tried to login using my username password in KiTTY (which is basically an improved PuTTY) and got the following error, shown in the screenshot.

Now, I can connect fine when using a Linux terminal. The authentication in this case is a little different because, after successful authentication it shows a menu with a number of options that you can select to start/stop/restart the server etc.

I googled a little and came to know that its something to do with Kerberos and authentication and I need to enable some settings in the SSH > Auth section of KiTTY. I tried enabling/disabling and tried everything in general, but still getting this error.

enter image description here

GSSAPI Settings in KiTTY

Any help is much appreciated

Thanks

share|improve this question
    
Which authentication method is your server using: password or public key? Please give us the output when you connect from Linux? –  quanta Sep 15 '11 at 13:03
    
its using public key –  detj Sep 15 '11 at 13:39

1 Answer 1

up vote 1 down vote accepted

It sounds like you haven't specified the private key for authentication:

enter image description here

share|improve this answer
    
Thanks a bunch! That was pretty stupid! –  detj Sep 15 '11 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.