Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using php 5.0 and IIS 5. When i am trying to access my application i get 2 erros like

PHP has encountered an Access Violation at 011173CD 

and

HTTP/1.1 500 Server Error Server: Microsoft-IIS/5.1 Date: Thu, 15 Sep 2011 10:26:36 GMT Content-Type: text/html Content-Length: 44 -2147417842 (0x8001010e)

I have no idea why it is coming. Please let me know how to solve this problem.

share|improve this question

migrated from webmasters.stackexchange.com Sep 15 '11 at 13:20

This question came from our site for pro webmasters.

add comment

1 Answer

Most of the time I find crashes like that in PHP due to version mismatches between IIS and PHP, or the same with extensions.

Ensure that the whole stack uses the correct version, architecture (32-bit vs. 64-bit), etc. and that they all match and are suggested to be used with one another. If using FastCGI, make sure it is patched and using the latest version. (That link is for IIS 7. Is there a reason you're using such an old version of IIS that you can't move to something not 10 years old? You're going to be plagued by problems if you don't upgrade that.)

If you're having startup problems or only problems when certain extensions are used, try disabling extensions to see if you can get it to launch without them to track down if one is causing a problem.

Try increase the logging levels by setting them lower, like to the Debug level perhaps.

If none of that works, you could try running Apache on Windows to see if that helps. Or just php.exe standalong to check if it is PHP-only vs. PHP + IIS problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.