Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Anyone know how I can stop Apache from logging this? It has no value, that I can see, and just clutters log in batches.

::1 - - [15/Sep/2011:10:26:29 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Sep/2011:10:26:30 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Sep/2011:10:26:31 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Sep/2011:10:26:32 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Sep/2011:10:26:33 -0700] "OPTIONS * HTTP/1.0" 200 -
share|improve this question

1 Answer 1

It looks like internal dummy connection. So, you can exclude them from your log with:

SetEnvIf Remote_Addr "::1" dontlog

and add env=!dontlog to the end of CustomLog directive:

CustomLog logs/access_log combined env=!dontlog
share|improve this answer
    
sry...I need to back up a bit - I'm a complete Apache newbist. Are these two lines to be added to httpd.conf or should they be executed from the a shell on the server? Apologies for my ignorance. –  Meltemi Sep 16 '11 at 21:01
    
They should be added to httpd.conf. –  quanta Sep 17 '11 at 1:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.