Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running RHEL 5.6 32bit. The server has ten (10) Ethernet interfaces:

eth0: bootproto=static, onboot=yes, ipaddr=192.168.0.1, netmask=255.255.255.0
eth1: bootproto=static, onboot=yes (no IP is configured for this interface, see below)
eth2-5: bootproto=none, onboot=yes (passive listening interfaces)
eth6-9: bootproto=none, onboot=no (disabled)

Eth1 is used as trunk link to two networks - I have configured two VLAN interfaces as well:

vlan620: vlan=yes, physdev=eth1, bootproto=static, ipaddr=172.16.37.4, netmask=255.255.255.240, gateway=172.16.37.1
vlan621: vlan=yes, physdev=eth1, bootproto=static, ipaddr=172.16.37.20, netmask=255.255.255.240, gateway=172.16.37.17

At any point in time, eth0 may grab one of the IPs assigned to vlan interfaces (172.16.37.4 or .20) - this happens at boot (when network service starts) or if network service is restarted, or randomly as the system is running. This can break VLAN connections and as these are the only links we have to this system someone would have to run out there with a monitor and keyboard to fix it by bringing the interfaces down and up. This is somewhat of an issue since the box is sitting in a server room in South America :) Can anyone at least suggest what is causing this problem?

EDIT:

As requested here is the output from the ls -i command:

[root@ssc-condor-smg1 ~]# ls -i /etc/sysconfig/networking/devices/ifcfg-eth*
17170452 /etc/sysconfig/networking/devices/ifcfg-eth0  17170447 /etc/sysconfig/networking/devices/ifcfg-eth5
17170451 /etc/sysconfig/networking/devices/ifcfg-eth1  17170446 /etc/sysconfig/networking/devices/ifcfg-eth6
17170450 /etc/sysconfig/networking/devices/ifcfg-eth2  17170445 /etc/sysconfig/networking/devices/ifcfg-eth7
17170449 /etc/sysconfig/networking/devices/ifcfg-eth3  17170444 /etc/sysconfig/networking/devices/ifcfg-eth8
17170448 /etc/sysconfig/networking/devices/ifcfg-eth4  17170443 /etc/sysconfig/networking/devices/ifcfg-eth9
[root@ssc-condor-smg1 ~]# ls -i /etc/sysconfig/network-scripts/ifcfg-e*
17170452 /etc/sysconfig/network-scripts/ifcfg-eth0  17170447 /etc/sysconfig/network-scripts/ifcfg-eth5
17170451 /etc/sysconfig/network-scripts/ifcfg-eth1  17170446 /etc/sysconfig/network-scripts/ifcfg-eth6
17170450 /etc/sysconfig/network-scripts/ifcfg-eth2  17170445 /etc/sysconfig/network-scripts/ifcfg-eth7
17170449 /etc/sysconfig/network-scripts/ifcfg-eth3  17170444 /etc/sysconfig/network-scripts/ifcfg-eth8
17170448 /etc/sysconfig/network-scripts/ifcfg-eth4  17170443 /etc/sysconfig/network-scripts/ifcfg-eth9
[root@ssc-condor-smg1 ~]# ls -i /etc/sysconfig/networking/profiles/default/ifcfg-e*
17170452 /etc/sysconfig/networking/profiles/default/ifcfg-eth0  17170447 /etc/sysconfig/networking/profiles/default/ifcfg-eth5
17170451 /etc/sysconfig/networking/profiles/default/ifcfg-eth1  17170446 /etc/sysconfig/networking/profiles/default/ifcfg-eth6
17170450 /etc/sysconfig/networking/profiles/default/ifcfg-eth2  17170445 /etc/sysconfig/networking/profiles/default/ifcfg-eth7
17170449 /etc/sysconfig/networking/profiles/default/ifcfg-eth3  17170444 /etc/sysconfig/networking/profiles/default/ifcfg-eth8
17170448 /etc/sysconfig/networking/profiles/default/ifcfg-eth4  17170443 /etc/sysconfig/networking/profiles/default/ifcfg-eth9
[root@ssc-condor-smg1 ~]#

I was not aware there are extra config files in these folders. I will verify they match.

EDIT: Files match line for line. The fun continues: since we rebooted the machine now all interfaces which are set to have no IP address pull one from vlan620 interface (.4). Only Interfaces that are set to ONBOOT=no stay shut off.

share|improve this question
    
You've got two typos in the eth0 config. Is that from typing them out or is that a copy/paste? –  Alo Sep 15 '11 at 20:41
    
Sorry I was just typing it out to get the relevant info out of there. I am diagnosing this over TeamViewer so that is great fun. –  Lukasz Sep 15 '11 at 22:04

2 Answers 2

How did you set up the network devices?

Please post the output of ls -i /etc/sysconfig/networking/devices/ifcfg-e* /etc/sysconfig/network-scripts/ifcfg-e* /etc/sysconfig/networking/profiles/default/ifcfg-e*

Note that the inodes for all config files have to match and that the same configuration must exist in these three locations.

This looks like there is DHCP active somewhere in your config.

share|improve this answer
    
Same thought here - we need more debugging info, and dhcp is likely getting called somewhere. –  Phil Hollenback Sep 15 '11 at 21:00
up vote 0 down vote accepted

I have found the culprit. After comparing services on this server with another which has identical configuration - even network scripts are the same line for line with exception of IP addresses - I found that the problem disappeared after stopping NetworkManager.i386 service. I have since deleted this package for good measure.

share|improve this answer
    
How did that package get there but not onto the other server? –  Nils Sep 16 '11 at 20:49
    
To clarify the package was installed on both but only running as service on the one giving me issues. It was disabled on the other one. –  Lukasz Sep 19 '11 at 18:24
    
Same question - why were the services set up different? Who did it and why? –  Nils Sep 19 '11 at 20:54
    
A very good question considering the I did the installs using RHEL5.5 DVD with minimal install option, and then only install things we needed (eg. SNMP, mySQL, apache etc.). –  Lukasz Sep 29 '11 at 17:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.