Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2nd Gen Drobo (the 4-bay with USB 2 and FireWire 800) which is hooked up to a computer that acts as an office file server. Lately I've noticed that it was seeming a bit slow, so I ran a bunch of tests to see if where the problem was. I ran some speed tests over the network to another USB drive and those went through at around 35MB/s. I then tested the drobo speed both on the server and another laptop and desktop. On all, the speed is fairly consistent at around 14MB/s (and read of 19MB/s). What worries me though is that the write speed graph is all over the chart. On the image below, the top test is the Drobo (looks basically the same on all systems) and the bottom test is another USB hard drive that I had around.

As you can see, the regular USB drive (while not super fast, it was a 4800RMP portable, laptop size, drive) is nice and consistent. The Drobo, however, is all over the place. I can't imagine that thrashing about is good for performance.

Since it's on multiple computers, it's not a USB controller or anything. So I worry the Drobo is going bad :( Or maybe could it be fragmentation or something else that could be fixed?



Shane's comment got me thinking... and I remembered that a friend of mine has a first gen Drobo, so I ran a test on that. Results below the first image, and yup, crazy all over the place on the write... maybe it IS just how Drobos are? But I would be remiss if I took that as empirical evidence of there not being a problem. The other Drobo could also have a problem. Especially since it's 2 years older than mine :P

DiskMark speed test

Friend's drobo (1st Gen)

share|improve this question
I'd be curious to see whether someone with another Drobo observes this same inconsistency. It may just be a side-effect of the extra software abstraction handling RAID between the filesystem and disks. – Shane Madden Sep 16 '11 at 1:14
@Shane - Definitely wondered the same thing. Tried googling for a reference to that effect, but I guess I didn't hit on just the right keywords to get anything useful. – Adam Haile Sep 16 '11 at 1:20

I have the exact same unit and did a quick test of my own. On linux, and I used iozone, and O_DIRECT (minimize caching effects). My read/write numbers for sequential are eerily like yours. 14MB/s write, 26 MB/s read. Mine's on firewire 400.

File size set to 524288 KB
Record Size 64 KB
O_DIRECT feature enabled
Command line used: iozone -s 512M -r 64k -i 0 -i 1 -I
Output is in Kbytes/sec
Time Resolution = 0.000001 seconds.
Processor cache size set to 1024 Kbytes.
Processor cache line size set to 32 bytes.
File stride size set to 17 * record size.

          KB  reclen   write rewrite    read    reread
      524288      64   13485   15283    26090    27290  

I do suspect some age related features are involved here, as it has been many months since I rebuilt the partitioning on it. I doubt the slowness can be remedied without a full rebuild, as the filesystem I ran the above test on is minimally consumed (5%) and highly unfragmented. As the above test is fully sequential, it's hard to get more ideal conditions then that.

share|improve this answer
Awesome, thanks for taking the time to run that. Well, guess it's good to know that it's probably not just my unit. And, actually mine has about 60% volume usage (though 0% fragmentation). I did just look back at my tests though and noticed that while it still showed the jumpiness, on my much newer laptop, the average speed was about 15-20% faster. Maybe it's just time for a new server... it is kinda old. – Adam Haile Sep 16 '11 at 2:02
@AdamHaile Heh, the server I ran my test on is a hand-me-down and is about 10 years old (whoa! time passes!). So, not the newest either! – sysadmin1138 Sep 16 '11 at 2:12
Ha, yeah... when I opened up my fileserver I noticed the year stamped on the motherboard read 2002! Time flies... didn't realize it was that old :P – Adam Haile Sep 16 '11 at 2:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.