Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have trouble with Windows Server 2008 R2, after updating XenServer tools the server starts in Recovery Console from Drive X, on Drive C is a system reserved partition and on Drive d there is the right Start Volume. But i don't know why the recovery console starts from drive x, can i start the System from drive d manually?

After type BCDEDIT there is following Entry. Can anyone tell me what does it mean?

Screenshot

I can solve this Problem, enter bcd boot d:\Windows set the Bootpartion to the right one, now i get the error that the Signature from xevtchn.sys is not valid, enter in extStart Option and set the Option to start without Signaturecheck starts the Server. Now uninstall the Driver and Install a new one solve this issue.

THX

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like your problem might be similar to this thread on the Citrix XenServer forums (http://forums.citrix.com/message.jspa?messageID=1460723)

Is it Windows 2008 SBS?

There is a hotfix from Microsoft (if this is your issue): http://support.microsoft.com/kb/2004121

If that is not your issue, you may have some luck in the Citrix XenServer forums ( http://forums.citrix.com/category.jspa?categoryID=101 ). I just did a quick search and got the information referenced above.

Also, Microsoft has some documentation on using the Recovery Console. Maybe there is a way to manually uninstall the drivers that XenTools put in place ( http://support.microsoft.com/kb/307654 )

The details of what is in the XenTools package in terms of drivers can be found here: http://forums.citrix.com/thread.jspa?threadID=235906

Maybe you can do a selective boot and not load the Xen drivers?

share|improve this answer
    
Hello Todd, thx for your Answer. But i still have this issue. I can't install the hotfix, when i try to log the boot process there is no ntbtlog.txt written to Systemroot. The Recovery Console starts from drive x and not from drive c. Drive c is system reserved and drive d is the normal Startdrive, since the update. Any suggestions? –  kockiren Sep 19 '11 at 8:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.