Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I guess the PHPMyAdmin code is getting confused by eaccelerator. This is the error I get:

Warning: Unknown: open_basedir restriction in effect. File() is not within the allowed path(s): (/usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/) in Unknown on line 0 

How do I fix that? Do I add the cache directories to the allowed open_basedir variables? If yes: where are they?

share|improve this question
    
Which PHP and eaccelerator version are you using? –  quanta Sep 16 '11 at 10:45
    
PHP version 5.3.2 and the latest eaccelerator: 0.9.6.1 –  skerit Sep 16 '11 at 10:51
add comment

2 Answers 2

Recompile the eaccelerator with --without-eaccelerator-use-inode option to see if this error go away.

share|improve this answer
add comment
<Directory /usr/share/phpmyadmin>
php_admin_value eaccelerator.enable 0
</Directory>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.