Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded solr from here and untar'd it. Then went to the example directory in apache-solr-3.1.0/solr/example and ran this command

java -jar start.jar

But when I open http://localhost:8983/solr/admin/

it shows like this

HTTP ERROR: 404 Problem accessing /solr/admin/.



Powered by Jetty://

I'm using Ubuntu 11.04. Why this problem is coming?

share|improve this question
  1. Stop Solr
  2. Go to the directory where you run "java -jar start.jar"
  3. mkdir work
  4. java -jar start.jar

It seems that Jetty will use the work directory if it exists, otherwise it uses /tmp

share|improve this answer

I've been experiencing this issue as well and finally found the details and resolution to the matter. The issue (as I understand) is specific to using Jetty as your servlet container.

The cause is that Jetty will place some files in the OS's /tmp directory--and occasionally the OS will delete them. In this scenario your admin pages will start returning 404's with the exception you've mentioned, but all searches and queries continue to execute as normal.

The solution is simple: creating a work subdirectory underneath your jetty.home folder (a runtime variable) will solve the problem. Jetty will see the work folder and will place temporary files in that location rather than in /tmp. The OS doesn't manage this location and therefore won't delete files that are still in use.

There is a bug report detailing this issue and resolution filed at:

share|improve this answer

It is probably better to ask for help on a different forum, because the problem you have does not seem to have any connection with ubuntu.

Anyway, one of the first hits on google brings me to: Try running:

    ant clean example 

prior to java -jar start.jar

share|improve this answer

If your install is running mostly with the defaults, then Jetty's work files are probably in /tmp where they may have been wiped.

Stop and restart Solr after creating a $(jetty.home)/work directory and you should stop seeing the 404s.

share|improve this answer
WHERE IS JETTY.HOME – Rahul Mehta Sep 17 '11 at 6:27
@Rahul Mehta its in gem file sunspot_solr-2.1.0\solr\etc\jetty.xml – Selva Feb 13 '14 at 8:32

I also had this problems and finally solved it with using version from here but only when I downloaded zip version. No Idea why.

share|improve this answer
Did you have the problem with 3.1.0 and found that 3.5.0 fixed it but 4.8.1 didn't? And you tried the .tgz which didn't work and then the .zip did? I strongly suspect you changed something else at the same time as trying the zip-encoded version 3.5.0 and that something else is the real reason it worked. – Ladadadada Jun 3 '14 at 10:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.