Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have Exchange 2003 and 2010 servers in our environment with IMAP access (non SSL) enabled to an Exchange 2010 client access server. After establishing an IMAP telnet connection and logging in as an Exchange 2010 mailbox user, if I execute

FETCH 1:* (FLAGS UID RFC822.SIZE INTERNALDATE BODY.PEEK[HEADER.FIELDS (Date To Cc From Subject X-Priority Importance Priority Content-Type)])

command, I receive a "BAD Command Argument Error. 11". However, the same command completes successfully without any errors for Exchange 2003 users. Also, the following command executes successfully as well for both versions:

FETCH 1:* (FLAGS UID RFC822.SIZE INTERNALDATE BODY.PEEK[HEADER.FIELDS ()])

It seems that the problem occurs only when I specify a header field. Do you have any idea what may cause this difference between the two Exchange versions?

share|improve this question
add comment

2 Answers

The IMAP code for Exchange 2010 is known to have some bugs; we found one a few months ago where the IMAP server was adding an extra linefeed for no reason to the end of a message, clobbering S/MIME validation.

Honestly, this sounds like a bug too, if you have premier support I'd suggest reporting the bug to Microsoft.

share|improve this answer
add comment

in my case it was due to a different language than English sit for the Regional Language, welcome screen, unicode and user settings in the administrative tab in control panel.

I changed everything to English and my problem is solved. Thanks to Microsoft support engineer for pointing this out! as I have changed only the unicode and didn't notice that if I didn't copy the settings to welcome screen and user settings then changes won't take effect and problems will continue to happen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.