Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have recently started using iptables, and I executed iptables -F without knowledge of what it might do. And suddenly I have lost connection to the node. I can't even ping the node. Any help would be highly appreciated!

share|improve this question

2 Answers 2

The iptables -F will have flushed (deleted) all of your rules, I guess your input policy is DROP so without any explicit ACCEPT rules you're locked out. Your best bet is to reboot the node and cross your fingers.

share|improve this answer

You flushed all your iptables rules, including the default ACCEPT. You'll need to either reboot the server (and hope that it loads up a proper set of rules) or get on the console and fix it from there.

share|improve this answer
    
I forgot to mention. It's a virtual node! No physical access to get the console :-( –  Ashwin Sep 16 '11 at 21:34
    
A proper VPS vendor will give you console access as well. I guess you'll need to reboot and hope for the best. –  EEAA Sep 16 '11 at 21:35
    
If you have a policy of accept then iptables -F doesn't lock you out - suck it and see. –  Iain Sep 16 '11 at 21:59
1  
Thanks! Will find a way to reboot, and try! :) –  Ashwin Sep 16 '11 at 22:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.