Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to deploy a branch office RODC and am getting an error about extending the domain and forest schema. I know I have already done this in the past but I went ahead and tried from the main office DC. I get an error saying its already been extended when I try to use adprep.

History: There is a currently a single Domain Controller at the main branch. There used to be 3 domain controllers at the other branches and the admin had Active Directory issues, so apparently he scaled back to the Domain Controller at the main office and gave the branches NAS storage. The branches are pointing across the VPN for DNS to the main branch DC.

I still see records in DNS for the old Domain Controllers, and I am not sure how he went about demoting them, or if it was done at all. I was going to deploy some branch RODC servers and cache some credentials so they can continue to work off of a Windows file server and SQL server even when the VPN is down.

Any suggestions for tools to help me find the problem?

share|improve this question
    
Can you please post about what command you are using where you get the error you describe in the first sentence of the first paragraph? Can you please cut-and-paste from the command prompt session the command and the response? –  Tom Ligda Aug 27 '12 at 23:43
    
You realize this question has been quiet for over a year? –  SpacemanSpiff Aug 28 '12 at 0:26

1 Answer 1

Did you go through the prereqs for an RODC available here:

http://technet.microsoft.com/en-us/library/cc731243%28WS.10%29.aspx

You must:

  1. Run adprep /rodcprep in order to extend your schema. This is more than the typical domainprep and forestprpe
  2. Be running your forest is running at 2003 level or higher
  3. Have at least 1 writable DC running Windows Server 2008 or 2008 R2 deployed in the domain you're trying to add an RODC to.
share|improve this answer
    
Dont know why but I didnt get an email alert to this. Well, unfortuntaely I did already run rodcprep, everything comes back good. Not sure where to look next... –  Jessica Moyer Sep 26 '11 at 0:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.