Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's my setup: I have one Mac Mini Server running OSX 10.7 Server set up as my network's primary file server. (I just finished installing it yesterday afternoon.) It shares files to 10 or so computers running Windows 7. So far, I have:

  • Created user accounts on the OSX machine with the same credentials as on Windows
  • Set them as Sharing Accounts
  • Created a group for the users
  • Shared several folders (all subfolders of /Shared Items) to the group with read & write permission
  • Mapped the shared folders as network drives on all the Windows machines

Everything was working just great - until one user (who happened to be my boss) tried to save a file on the public directory and access it from another machine. He got a 'permission denied' error. I popped open Terminal and checked, and the directory was set to drwx------, and all the files in the directory were set to -rwx------.

To keep things moving along until I figure out what's going on, I enabled the root user and made a crontab to chmod -Rv 777 the /Shared Items directory once a minute, but it's a dirty hack and I don't like it.

Everything was configured through the Settings GUI in OSX. smb is enabled and is being used. What am I doing wrong, and how can I fix this?

share|improve this question

1 Answer 1

I highly doubt a 700 would be the default permissions set by the GUI, but at least go look at the share options in the Server Admin utility (these steps are for 10.6, I don't know if 10.7 is the same).

-Open up the server admin, authenticate to your server.

-Click on the "File Sharing" tab and then the "Share Points" sub-tab.

-Select your share point. In the Window describing the share point, you should have two tabs that say "Share Point" and "Permissions". Select "Share Point".

-Under the Share Point tab there's a "Protocol Options" button. Within that window, select the SMB tab and then set the permissions as desired for the new files and folders section.

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.