Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Windows Server 2008 R2 I have various admin consoles/snapins installed. All of these run correctly, whether I launch them directly or add them to MMC.

However, if I try to launch them from the command line or from a batch file I get the above error.

No errors or relevant information is logged in the event logs. I have tried deleting the files from AppData\MMC and have also tried re-registering msxml3.dll.

Any other suggestions?

PS the reason I need to do this is that I'm trying to publish them via Citrix.

share|improve this question
1  
from the CLI, are you executing them using an elevated command prompt? –  SpacemanSpiff Sep 20 '11 at 0:21
    
@SpacemanSpiff - no, but I do get a UAC prompt to launch MMC anyway. –  Matt Sep 20 '11 at 0:57
    
@SpacemanSpiff - just to verify, running with elevated privileges makes no difference. –  Matt Sep 20 '11 at 0:59

1 Answer 1

up vote 0 down vote accepted

My next steps would be a) trying to run the consoles in 32-bit environment as "mmc /32 compmgmt.msc" and if it doesn't help b) running "sfc /scannow"

share|improve this answer
    
Hmm I was trying to force it to use 64 (32 bit won't work for some of the consoles). I'll try your suggestions and see how they go. Thanks –  Matt Sep 20 '11 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.