Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Whm cPanel VPS server running CentOS 5 for domain.com.au

I have www.domain.com.au running on 192.168.0.1 with a GoDaddy EV SSL certificate

I have the subdomains such as large.domain.com.au, css.domain.com.au etc running on 192.168.0.2 with a GoDaddy Wildcard SSL certificate, I installed the wildcard SSL using these instructions: http://www.thecpaneladmin.com/installing-wildcard-ssl-certificate/

However, when going to a subdomain in Google Chrome, I get the error message "you attempted to reach large.domain.com.au, but instead you actually reached a server identifying itself as www.domain.com.au...": http://imageshack.us/photo/my-images/37/sslerror.png/

The wildcard SSL looks like its been installed: http://imageshack.us/photo/my-images/38/unledevv.png/

The subdomains where setup in the subdomain section in cPanel for www.domain.com.au, the subdomains where setup so that: large.domain.com.au/images/example.jpg returns domain.com.am/images/example.jpp (without redirection)

When accessing the subdomain via http and not https, the image returns correctly as per normal, but when accessing via https the SSL error appears even after giving it a IP address and installed a wildcard SSL, also even after telling Google Chrome to ignore the error, the image does not return.

Any clues?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Well, first thing is SSL won't work for virtualhosts in apache. The reason is well explained at: http://wiki.apache.org/httpd/NameBasedSSLVHosts . For your current situation, I assume the subdomains are using different document roots and if this is the case, you won't be able to make the current setup work for you.

When you connect to the server via ssl url, it will pull the ssl certificate installed in the corresponding IP (as name based recognition is not possible) and the pages will be served from the document root defined under the corresponding virtualhost.

However, as from the details you have provided, you are not suppose to get the error "you attempted to reach large.domain.com.au, but instead you actually reached a server identifying itself as www.domain.com.au..." ; if you actually installed the wildcard SSL. So, I still doubt you actually installed the wildcard SSL.

If your subdomains are using different document roots and you want to install SSL for all of them, then you have to follow the steps below,

  1. Remove the subdomain from cPanel and create subdomain as you normally create regular domain in WHM >> Account Functions >> Create Accounts option.

  2. Assign a dedicated IP to the subdomain.

  3. Install the same wildcard certificate for the subdomain from your WHM.

By this way, apache will be able to serve SSL pages for subdomains from the corresponding document root with the same wildcard SSL certificate.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.