Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting some errors when trying to update some RHEL 6.1 64 bit servers with yum. I tried a fresh install of the OS and then ran yum -y upgrade and received the same errors that I was getting on my production servers.

I've tried yum -y upgrade --skip-broken and rpm -Va --nofiles --nodigest and neither seemed to help.

I think the problem might be that we are missing a package on our satellite servers, but I'm not really sure. Any help would be greatly appreciated.

--> Processing Dependency: /bin/sed for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /bin/sed for package: policycoreutils-2.0.83-19.8.el6_0.x86_64
--> Processing Dependency: /bin/sed for package: groff-1.18.1.4-21.el6.x86_64
--> Processing Dependency: /bin/sed for package: initscripts-9.03.23-1.el6.x86_64
--> Finished Dependency Resolution
Skip-broken could not solve problems
Error: Package: initscripts-9.03.23-1.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
       Requires: /bin/sed
       Removing: sed-4.2.1-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
           Not found
       Updated By: sed-4.2.1-7.el6.x86_64 (rhel-x86_64-server-fastrack-6)
           Not found
Error: Package: redhat-lsb-4.0-3.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
       Requires: /bin/sed
       Removing: sed-4.2.1-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
           Not found
       Updated By: sed-4.2.1-7.el6.x86_64 (rhel-x86_64-server-fastrack-6)
           Not found
Error: Package: groff-1.18.1.4-21.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
       Requires: /bin/sed
       Removing: sed-4.2.1-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
           Not found
       Updated By: sed-4.2.1-7.el6.x86_64 (rhel-x86_64-server-fastrack-6)
           Not found
Error: Package: policycoreutils-2.0.83-19.8.el6_0.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
       Requires: /bin/sed
       Removing: sed-4.2.1-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
           Not found
       Updated By: sed-4.2.1-7.el6.x86_64 (rhel-x86_64-server-fastrack-6)
           Not found
 You could try running: rpm -Va --nofiles --nodigest
share|improve this question

3 Answers 3

up vote 4 down vote accepted

I ran into the same problem and was able to resolve it by manually updating the sed package:

rpm -Uvh ftp://ftp.ntua.gr/pub/linux/scientificlinux/6.1/x86_64/updates/fastbugs/sed-4.2.1-7.el6.x86_64.rpm

After that installed, I was able to run yum -y update without any problems.

share|improve this answer

This is kind of weird, the output says:

Error: Package: initscripts-9.03.23-1.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
   Requires: /bin/sed
   Removing: sed-4.2.1-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
       Not found
   Updated By: sed-4.2.1-7.el6.x86_64 (rhel-x86_64-server-fastrack-6)
       Not found

...which means that yum wants to upgrade from sed-4.2.1-5 to sed-4.2.1-7, but it thinks that if it does so then the newer package doesn't provide /bin/sed ... so a bunch of things fail because they depend on exactly that path.

It's possible this is true, but it seems like a really weird error for Red Hat not to have caught.

In general I've never needed --skip-broken for RHEL ... so I'm a bit suspicious of if you have some weird repo. setup (ie. fastrack but nothing else).

I'd run "yum repolist" and see what it says, and drop the --skip-broken and see what that says.

share|improve this answer
    
yum repolist says that I have the following repositories rhel-x86_64-server-6, fastback, optional, and supplementary. –  Kyle Oct 7 '11 at 17:32

Run:

yum search sed
yum update -y *sed package from search*

Make sure you have updates repo enabled in /etc/yum.repos.d/reponame.repo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.