Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just setup a VPN for our company last week. I gave it its own static assigned IP address pool and its not always giving the correct DNS enteries. Sometimes it works sometimes you cannot ping the name of the server/workstation but you can ping their IP addresses.

I forwarded the dedicated external IP address for port 47 and 1723 to the VPN server and it connects correctly.

Has anyone had this trouble before?

Thanks!

share|improve this question

2 Answers 2

the DNS servers being assigned are 0.0.0.0 and the subnet mask is 0.0.0.0. it does however get a valid IP address. when I manually set the DNS servers to our internal DNS servers everything works great. Anyone know how to manually add this to the settings for the VPN server?

share|improve this answer
    
Hmmm... Do you have DNS servers configured on the server NIC that's used for incoming RRAS connections? It sounds like you don't. –  joeqwerty Sep 22 '11 at 18:43

When you use a static ip address pool the VPN server assigns the DNS servers to the VPN clients from the TCP properties of the server NIC that the VPN clients connect to. Can you confirm that those are the DNS servers being assigned to the clients? If they aren't, what DNS servers are being assigned to the VPN clients?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.