Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am creating a RAID 10 array over four iSCSI targets. I want to control everything manually though so I can run it through heartbeat. I've unlinked the open-iscsi and mdadm scripts from /etc/rc#.d/ but the raid array is still recreated on boot up. Once the server boots up I have to do a mdadm --stop /dev/md0 and then /etc/init.d/mdadm stop to make sure it doesn't fire it up again. I commented out my array from /etc/mdadm/mdadm.conf but it just created a new one later. How can I put mdadm into a manual process so it only attempts to start or rebuild the array when I tell it to?

share|improve this question
up vote 2 down vote accepted


   # by default, scan all partitions (/proc/partitions) for MD superblocks.
   # alternatively, specify devices to scan, using wildcards if desired.
  DEVICE partitions

what about scan something like /dev/null ? I mean some devices without superblocks. So mdadm cant find arrays.

share|improve this answer
That worked. Thanks. – J.R. Sep 20 '11 at 20:24

You don't mention what flavour of Linux you are using (I'm assuming Linux?). You can control startup behaviour on debian/ubuntu with

dpkg-reconfigure mdadm
share|improve this answer
Ubuntu 11.04. I tried that and the only startup it asks about is the monitor which I had already turned off. – J.R. Sep 20 '11 at 20:15

From a RHEL 6.7 setup adding AUTO -all in /etc/mdadm.conf to disable all auto-assembly, except for ARRAYs/DEVICEs otherwise specified, seems to do the trick.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.