Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up UltraVNC single click with encryption via MSRC4Plugin.dsm.

With encryption, it won't work at all.

Without encryption, it will connect but generates an error and seems to be trying to load the dsm plugin.


Settings are as follows:


For generating the sc executable: helpdesk.txt

... Some stuff removed...

[HOST]
Encrypted Connection
-plugin -connect ipaddress:59100 -noregistry

[HOST]
Regular Connection
-connect ipaddress:59100 -noregistry

... Some stuff removed...


Here's what happens WITHOUT encryption:


On my box, I run the viewer as:

"C:\Program Files\UltraVNC\vncviewer.exe" -logfile viewer_%date:~10,4%-%date:~4,2%-%date:~7,2%.log -listen 59100

On the SC box, I run the exe and click the "Regular Connection" option.

On my box,

I get an alert window that says: Title: Plugin Loading. Message: The plugin cannot be loaded. Please check its name integrity.

If I click "ok" I get an "accept incoming SC connection" box. If I click yes, the connection opens and I am controlling the SC box.

It works, is not secure (not supposed to be) but is still trying to load the dsm for some reason, and not finding it. But it will connect.

View Log (on my box) is as follows (note the version difference - could that be it?):

RFB server supports protocol version 3.16
Connected to RFB server, using protocol version 3.4
No authentication needed
Desktop name "WinVNC "
Cache: Cache buffer bitmap creation
rdr::Exception (1): rdr::EndOfStream: read


Here's what happens WITH encryption:


On my box, I run the viewer as:

"C:\Program Files\UltraVNC\vncviewer.exe" -logfile viewer_encrypted_%date:~10,4%-%date:~4,2%-%date:~7,2%.log -dsmplugin MSRC4Plugin.dsm -listen 59100

On the SC Box, I run the exe and select the "Encrypted Connection" option. It goes to "connecting" status and just sits.

On my box, there is no indication that anything is happening.

On the SC Box, I close sc from the waiting icon.

On my box, I get a popup saying: Connection failed - error reading protocol version. Possible causes: You've forgottent o select a DSMPlugin and the server uses a DSM Plugin.

Viewer log (on my box) is as follows:

rdr::Exception (2): rdr::EndOfStream: read
Error reading protocol version: WriteExact: Socket error while writing.


Things to note:

  • I do have matching rc4.key files in the SC exe and the server.
  • I do have the MSRC4Plugin.dsm file in the /UltraVNC/ folder.
  • I have completely removed and installed everything fresh, directly from the uVNC site.
  • The MSRC4Plugin.dsm file may not be the newest. I think it is though, as it came with the uVNC.
  • My ports are all forwarding correctly, and I'm not having any problems connecting other than this one.

Any help much appreciated.

Thanks!

share|improve this question
    
Which version of the UltraVNC viewer are you using? Have you tried the latest version? –  stukelly Jun 25 '09 at 19:21
    
Yes, this is all with fresh installs of the latest versions of everything. –  Eli Jun 25 '09 at 22:13
add comment

1 Answer

up vote 0 down vote accepted

UltraVNC have just released an new update. Try version 1.0.6.4 and see if it fixes your problem.

You should try posting your question on the UltraVNC forums.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.