Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've hit problems installing munin on Centos 6. This seems to be a conflict between parts of Perl. I think the version of Perl is newer on Centos 6 (v5.10.1)

When installing munin via yum I get errors relating to perl dependencies as below. I'm not a big enough whiz at yum or rpm to figure out the issue. Munin documentation does not yet talk about installing to Centos 6.0

Error: Package: munin-node-1.4.2-0.rpl1.el5.noarch (/munin-node-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(Net::SNMP)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: bitstream-vera-fonts
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(HTML::Template)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl-Net-SNMP
Error: Package: munin-common-1.4.2-0.rpl1.el5.noarch (/munin-common-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-node-1.4.2-0.rpl1.el5.noarch (/munin-node-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(DBI)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(Log::Log4perl)
Error: Package: munin-node-1.4.2-0.rpl1.el5.noarch (/munin-node-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(LWP::Simple)
Error: Package: munin-node-1.4.2-0.rpl1.el5.noarch (/munin-node-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(RRDs)
Error: Package: munin-node-1.4.2-0.rpl1.el5.noarch (/munin-node-1.4.2-0.rpl1.el5.noarch)
           Requires: perl-Net-Server
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(Date::Manip)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl-Net-Server
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(CGI::Fast)
Error: Package: munin-1.4.2-0.rpl1.el5.noarch (/munin-1.4.2-0.rpl1.el5.noarch)
           Requires: perl(Time::HiRes)
share|improve this question
1  
What repository are you installing munin from? For CentOS 6, munin version 1.4.7 is in EPEL. –  Andy Shinn Jun 23 '12 at 0:19
add comment

4 Answers

up vote 1 down vote accepted

A potential problem is that you're trying to install EPEL5 packages on CentOS6. You should get your packages from EPEL6.

You can find the latest repo rpm at: http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-7.noarch.rpm

Once it starts installing and looking for the correct packages, things should get easier.

share|improve this answer
add comment

You need to install the required Perl modules before installing munin.

share|improve this answer
    
any idea how you do that? like via CPAN or something, or can I do it with yum –  justinhj Sep 21 '11 at 16:22
    
You are free to chose your option. Both is possible. –  mailq Sep 21 '11 at 16:27
add comment

RPM package names that have '.el5' are for Centos5 or RHEL5. Instead of trying to install munin-1.4.2-0.rpl1.el5.noarch, which is meant for Centos5 or RHEL5, you need to install the Centos6 version of munin.

share|improve this answer
add comment

You could try using --skip-broken to work around the problem.

You could try running: rpm -Va --nofiles --nodigest

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.