Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed ruby from source, and everything ruby related seems to work just fine. I can't install anything that depends on ruby using apt because I don't want 2 versions of ruby installed. After I install mcollective from dpkg using --ignore-depends, apt-get stops working entirely.

root@puppet:~# apt-get install ganglia-monitor
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ganglia-monitor : Depends: libconfuse0 (>= 2.5) but it is not going to be installed
                   Depends: libganglia1 (= 3.1.7-1+b1) but it is not going to be installed
 mcollective : Depends: ruby (>= 1.8.1)
 mcollective-client : Depends: ruby (>= 1.8.1)
 mcollective-common : Depends: ruby (>= 1.8.1)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I don't want to remove mcollective, but when I try that, everything works again. Does anyone know a workaround to tell apt to stop looking for ruby? Thanks, matt.

share|improve this question
up vote 1 down vote accepted

Use equivs to build a dummy package of ruby with a version of 1.8.1 or higher -- see this page, and replace all instances of "package-minimal" with "ruby", and all instances of "1.0" in the version number with the version number of your separately-built Ruby.

share|improve this answer
I'll have a look at that and give it a shot. – matt Sep 21 '11 at 22:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.