Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a CIFS share that will mount automatically on my OpenSolaris server. It seems like it would be simple enough, but there's something wrong in my syntax that's preventing it from mounting.

The line in /etc/vfstab looks like:

//user:password@192.168.2.1/data      -       /mount_point   smbfs   -       yes     -

However, when I try to mount it using mount /mount_point I get an error message:

mount: Mount point cannot be determined

I've scoured the man pages and the net, but I can't see what I am doing wrong.

Edit: I do have the svc:/network/smb/client service started, and I am able to mount the volume manually using mount -F smbfs ...., but so far no luck with either vfstab or autofs.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

You might try setting up a .nsmbrc file. I abandoned using OSOL as my desktop OS before I got it resolved, but I think there's a bug in using Automounter + CIFS : here's my post to the osol forums: http://opensolaris.org/jive/thread.jspa?messageID=398091

Now for the easy things, sorry, they have to be asked:

  1. /mount_point actually exists, right?
  2. Solaris' mount command and bash completion don't play nice together. If I run:
    mount /mount_point
    on a normal mount, it works fine, but if I add the trailing slash that tab-completion adds for me, it reports the same error:
    mount /mount_point/
share|improve this answer
    
Ah, you are correct! I didn't catch that before. However, now I get "device busy" instead. Hmm –  Kamil Kisiel Aug 11 '09 at 16:07

I don't think vfstab supports CIFS shares. You should be using automounter instead: How to Add an Automounter Entry for a CIFS Share

share|improve this answer
    
According to man 1 mount_smbfs, it should be mountable through vfstab. In any case, I tried it through the automounter as well but it seems to just stall when trying to access the automount location. And again, mounting manually works just fine. –  Kamil Kisiel Jul 2 '09 at 23:27

You can use cifs mounts in /etc/vfstab - read about it in the mount_smbfs manual page.

Have you started the samba client?

svcadm enable smb/client
share|improve this answer
    
Yes it is enabled and I can mount the volume manually. I updated the question with more details. –  Kamil Kisiel Jun 29 '09 at 18:50

CIFS does work in /etc/vfstab on OpenIndiana, I've just done it. This is the correct line to get it to work. Also check your /mountpoint is correct. The fileperms, dirperms are just an example of options.

The correct line is:

//WORKGROUP;username:password@host/share    -   /mountpoint smbfs   -   no  fileperms=0777,dirperms=0777
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.