Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a blade server of HP proliant with 64 Gb of RAM and 1TB hard-disk. I installed Cent OS 5.6 with XEN enabled on it.

I used xenbr0(xenbridge) mode and not virbr0 mode for configuring my networking in XEN.

I was successful in installing virtual machines on it and cloning them. I started 8 of these VMs and everything worked fine, but when I started 9th VM (excluding Dom-0) following error came.

"Error starting domain : post operation failed:xend_post:error from xen daemon:(xend.err) 'Device 768(vbd) could not be connected. Failed to find an unused loop device"

I tried searching for the solution and found that I need to increase "options netloop nloopbacks". I did it in /etc/modprob.d file and rebooted the system but it didn't work either.

I didn't understand it but am I doing something wrong here. I target to install *100 VM*s on this machine as I have enough hardware resources. Is it possible? and if yes how can I solve above problem?

share|improve this question
up vote 1 down vote accepted

you need to create more loopback devices (/dev/loopX where X is 0-7). By default there is 8

If you have loopback compiled into the kernel (which most people do) you can add this to the kernel line in /boot/grub/menu.lst


Then reboot

Also, you can try editing /etc/modprobe.conf and adding

options loop max_loop=128

share|improve this answer
Thank you very much man, it really helped. – stillStudent Sep 21 '11 at 14:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.