Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install PHP on Ubuntu 11.04. I am compiling from source.

Here are my installation dependencies:

apt-get -y install php5-dev php-pear

apt-get -y install libxml2-dev libevent-dev zlib1g-dev libbz2-dev libgmp3-dev
libssl-dev libcurl4-openssl-dev libjpeg-dev libpng-dev libgd2-xpm-dev
libmcrypt-dev memcached libmemcached-dev libc-client-dev libkrb5-dev

And here is my configure script:

./configure --enable-fpm --enable-cli --with-fpm-user=php-fpm
--with-fpm-group=php-fpm --prefix=/usr/local/php --exec-prefix=/usr/local/php
--enable-bcmath --enable-ctype --with-curl --with-curlwrappers --enable-dba
--with-cdb --with-flatfile --with-inifile --enable-exif --enable-ftp
--disable-fileinfo --with-gd --with-jpeg-dir --with-png-dir --with-zlib-dir
--with-xpm-dir --with-ttf --with-freetype-dir --enable-gd-native-ttf
--with-gettext --with-gmp --with-imap --with-imap-ssl --with-ldap
--with-ldap-sasl --enable-mbstring=all --with-mcrypt --with-mhash --with-mysql
--with-mysqli --with-pdo-mysql --with-openssl --with-kerberos --with-pspell
--enable-shmop --enable-simplexml --with-snmp --enable-soap --enable-sockets
--with-tidy --enable-wddx --enable-xmlreader --with-xmlrpc --with-xsl
--with-zip --with-zlib --enable-sysvsem --enable-sysvshm

However, I get the following error:

configure: error: Kerberos libraries not found.

Check the path given to --with-kerberos (if no path is given, searches in
/usr/kerberos, /usr/local and /usr )

I did not provide a path, but there is no directory like /usr/kerberos.

Does it mean kerberos is not installed on my server, and if not do I need to install it to get this to work, and how?!

share|improve this question

Here's a post from a user who solved this by running configure under sh -x, which lets you see how it is figuring out which directories to look in. In this example, it was a lib vs lib64 directory issue that stopped PHP finding kerberos, but even if it's something else, it may help you discover what you need to set --with-kerberos to.

share|improve this answer
Thanks. From what I see it's looking for kbr5-config in /usr/bin, which happens to be there. The thing is, I don't know where kerberos is supposed to be on my system. I can't find any directory called kerberos or krb under /usr or /usr/local or /usr/lib and /usr/lib64 is a symlink to /usr/lib. Not sure if kerberos is something I should be installing separately? – Obi Hill Sep 21 '11 at 16:59
libkrb5-dev should be all you need. You can check you have all the build dependencies with apt-get build-dep php5-common. – crb Sep 21 '11 at 20:09
Ok. I tried that but I still get the same error. I'm wondering if it's an issue specific to Ubuntu Natty. I'm going to try it on Lucid and see what happens. – Obi Hill Sep 22 '11 at 14:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.