Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to get xdebug to work on my ubuntu 11 04 server. Everything seems setup right and I do see xdebug from phpinfo(). I installed with apt-get install php5-xdebug. The problem is that anytime I put my workstation(windows 7) ip in xdebug.ini as

zend_extension=/usr/lib/php5/20090626+lfs/xdebug.so

[debug]
; Remote settings
xdebug.remote_autostart=off
xdebug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=192.168.0.49
xdebug.remote_port=9000
xdebug.remote_log=/home/someone/xdebug.log

No webpage works. They just timeout for everyone connected to this server. If I put a coworkers ip in (he is on linux) web pages load without problem. I tought maybe my port 9000 was blocked by windows firewall but I opened the port and everything and still it hangs.

I hope I am clear. I do not see anything in xdebug.log or apaches error logs. I do restart apache after every changes to xdebug.ini. ALso as I said xdebug does load since it shows up in phpinfo().

I'll add any info you guys deeme necessary I am not sure what you need to help me. I found this question but no one helped him:(

edit: other things I have tried, disabling antivirus, starting a debug session from netbeans. Nothing works.

share|improve this question

1 Answer 1

On the Ubuntu machine, try telnet 192.168.0.49 9000 (or nc 192.168.0.49 9000) to see if you come through.

You can also turn on the remote_log it should record all attempts of sending debugging information to your host:

xdebug.remote_log=/tmp/xdebug.log
share|improve this answer
    
Hi and thanks for taking the time to help! Telnet fails to connect and I did enable remote_log but its empty. –  Iznogood Sep 27 '11 at 13:08
    
Telnet failing to connect shows that your Windows system is not ready to receive the debugging information. Do you use an IDE? You need to enable the debugging port there. –  akirk Sep 28 '11 at 14:05
    
I use netbeans and zend studio 8. I did enable the debuging port (9000) there. –  Iznogood Sep 28 '11 at 15:03
    
yes but obviously you don't come through to that port. so it might be a firewall or malware protection after all. –  akirk Sep 28 '11 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.