Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was trying to install Zend server on a virtual server through SSH. The address http://localhost works fine. But when I visit http://localhost:10081 to start the configuration, but I got an error "An unexpected error has occurred“. Then I checked the log file located at /usr/local/zend/var/log/zend_server_ui.log. The cause is as below:

Zend Server Exception Caught:
Permission denied '/usr/local/zend/gui/application/data/zend-server.ini'
#0 /usr/local/zend/gui/application/CE/models/Plugins/Initializer/CE.php(128): Common_ApplicationModel::loadConfiguration()
#1 /usr/local/zend/gui/application/CE/models/Plugins/Initializer/CE.php(38): Plugins_Initializer_CE->initApplication()
#2 /usr/local/zend/gui/application/Initializer.php(34): Plugins_Initializer_CE->__construct()
#3 /usr/local/zend/gui/html/index.php(24): Initializer::getInitializer('CE')
#4 {main}

It says the permission was denied for the zend-server.ini file. But the I think I have the permission on that file:

-rw-rwSr-- 1 root zend    998 2011-09-21 19:39 zend-server.ini

Please help. Thanks in advance.

share|improve this question
I fixed the issue by grant 777 permission to the zend-server.ini file. Not sure if this is the right way, but it works now. –  Shichao Sep 21 '11 at 20:18
777 should only be last resort solution since it gives everyone full privileges on the file in question. Instead you could probably have fixed it by adding the user Zend Server was running as to the group who owned the file and given the group read and write privileges or something like that. Or altered who was running the Zend Server. –  inquam Sep 2 at 11:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.