Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running IIS 7.5 on my local machine (Windows 7 Home Premium) and localhost works for about three requests and then stops taking requests. The strange thing is when I switch to calling it with 127.0.0.1, I can access the page again but then the same thing happens. Then I switch to my local IP 192.168.1.X and it works again but then the same thing.

I've tried to recycle the app pool to see if the app was hanging but I am not getting any luck with that. I have also killed the process and tried to restart IIS. The only thing the pseudo-works is restarting but then it's the same behavior described above.

I have checked the failed request logs and see no record of errors. Is there somewhere I can look to get more information?

I was working on Windows Ultimate and it was working well, but that machine died last weekend. Waiting for the new machine to come in.

At this point I am baffled and considering a career change, I think pizza maker (just kidding).

share|improve this question
    
When you say it "stops taking requests", do you see a "Page cannot be displayed..." in the browser? Did you check the System event logs for warnings or errors in the relevant time frame? The logs you checked for failed requests, was that the W3SVC log in IIS? –  Somantra Sep 22 '11 at 13:36
    
I do not see a Page cannot be displayed and nothing in the event logs. The page just sits there until I get a 504: Gateway timeout. –  Khalid Abuhakmeh Sep 22 '11 at 14:10
    
The likely cause appears to be a networking issue (see: forums.asp.net/t/906305.aspx). I would suggest reproducing the issue while inspecting the traffic with fiddler, wireshark et al. –  Somantra Sep 22 '11 at 14:33
    
Here is the interesting part, I get one shot with each kind of web browser on my machine. So if I have exhausted my "trys" with Google Chrome I can switch to IE and Firefox, but I go through the same steps. Once I've exhausted all the browsers I have to restart the machine. –  Khalid Abuhakmeh Sep 22 '11 at 14:34
    
It seems that IIS begins to respond again once I clear my cookies for that particular domain. I have been looking at Fiddler and there isn't anything happening there. –  Khalid Abuhakmeh Sep 22 '11 at 16:03
add comment

2 Answers 2

It sounds like something could be binding to the port. Trying using netstat to see what is listening on port 80.

The following command will list each listening process, the port and the process ID. You can then use the process ID to determine the what is using that port.

netstat -an -o |find /i "listening"
share|improve this answer
    
The result of running that are here gist.github.com/1234862 –  Khalid Abuhakmeh Sep 22 '11 at 14:11
1  
Right, so you need to find out what process ID 4 is. Easiest way is to look in task manager process tab, add the process ID column and see what it is. –  Sam Sep 22 '11 at 16:11
    
Process 4 is 'System' –  Khalid Abuhakmeh Sep 22 '11 at 16:26
2  
Which is HTTP.SYS, which is completely normal for IIS. –  TristanK Sep 23 '11 at 4:26
add comment

Psychic debugging:

You're running IIS with ASP in session mode or ASP.Net in debug mode, and the app's hanging. You get one request through per unique browser session, from the sound of it.

Then again, if that were the case, recycling would work. If you kill the w3wp.exe process, does a new one start with the next request?

If so: Fix the app so you can send more requests to it.

share|improve this answer
    
Sorry psychic debugger, killing w3wp.exe or recycling doesn't fix the issue. Once IIS decides to stop it just stops. The funny thing is, I've been running the site on other developer machines with the same exact configuration and they work fine. I have a new iMac sitting behind me. It might just be time to give up on this problem. –  Khalid Abuhakmeh Sep 23 '11 at 19:47
    
If a new w3wp doesn't launch, WAS or HTTP.SYS is broken, implying a problem with the applicationhost.config. If antivirus is in the mix, it might be being helpful. –  TristanK Sep 24 '11 at 1:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.