Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying create a cluster with existing data directory on Debian 2.6.26-2-686-bigmem. I use PostgreSQL 8.3 installed from apt-get and PostgreSQL 9.1 installed from OpenSCG I want to create cluster with existing data directory and add it to postgres-commons using command:

pg_createcluster -d /opt/postgres/9.1/data/ -e UTF8 --locale ru_Ru -p 6432 9.1 MAIN_RU

The result is:

Error: invalid version: 9.1

I found this question Can't create clusters in PostgreSQL 9.0 but it seems in my case the problem is in postresql-commons package or in PostgreSQL 9.1 package that is installed.

aptitude show postgresql-common
Package: postgresql-common
New: yes
State: installed
Automatically installed: yes
Version: 94lenny1
Priority: optional
Section: misc
Maintainer: Martin Pitt <>
Uncompressed Size: 496k
Depends: postgresql-client-common (>= 94lenny1), procps, adduser, debconf (>=
     0.5.00) | debconf-2.0, lsb-base (>= 3.0-3)
Recommends: ssl-cert (>= 1.0.11)
Conflicts: postgresql (< 7.5), postgresql-7.4 (< 1:7.4.8-10), postgresql-8.0 (<
       8.0.3-7), postgresql-client (< 7.5)
Replaces: postgresql (< 7.5), postgresql-client (< 7.5)


I check this on Ubuntu 2.6.32-24-generic #39 with same deb packages, the problem is the same. I think it's in postgresql-commons facilities packaged in OpenSCG deb. PostgreSQL 9.1 is released 2011-09-11.

share|improve this question
Is pg_createcluster from version 8.3? Postgres command line utilities aren't forward compatible. – Dana the Sane Sep 22 '11 at 18:49
How can I determine from what package pg_createcluster is? Doesn't is belongs to postgresql-commons package? – Viktor Stolbin Sep 22 '11 at 21:47
Run the utility with the --version flag. – Dana the Sane Sep 23 '11 at 14:56
up vote 0 down vote accepted

It looks like you are mixing Debian and OpenSCG packages. That won't work. Install PostgreSQL 9.1 from Debian.

share|improve this answer
It seems there's no 9.1 version package in Debian lenny link? – Viktor Stolbin Sep 22 '11 at 21:49
Build yourself a backport if you want your installation integrated with the postgresql-common infrastructure. – Peter Eisentraut Sep 23 '11 at 15:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.