Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Below is some configurations in my php.ini

error_reporting = E_ALL & ~E_DEPRECATED
display_errors = Off
log_errors = On

I get a lot of Deprecated errors, in my error log, which I wanted to skip. I think if I set log_errors = Off, it will completely shut off the server log. So is there any way I can stop only deprecated errors writing into my error log?

Thanks!

share|improve this question

1 Answer 1

Checkout the existing stackoverflow thread which discussed regarding the same issue.

share|improve this answer
    
Thanks! That does not work for me. Also, I am using nginx. –  Adam C. Sep 23 '11 at 0:14
    
So far, what all settings you tried.? did you restarted apache/nginx after making the changes ?. Could you add more details on all the configurations that you have tried, to the question. –  SparX Sep 23 '11 at 0:20
    
I added the following into my php.ini and restarted nginx, but I still see deprecated errors in the error log. php_admin_value error_reporting 22527 php_admin_flag log_errors On php_admin_flag display_errors Off –  Adam C. Sep 24 '11 at 3:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.