Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using the Quest commandlets for a very simple and straightforward update but it's not working. No errors, it just fails to change the value:

Set-QADUser ttest -ObjectAttributes @{office="ABQ"}

Can't get much simpler - what am I doing wrong? both of these work fine:

Set-QADUser ttest -objectAttributes @{otherTelephone=@('555-34-67','555-34-68')}
Set-QADUser ttest -objectAttributes @{otherTelephone=''}

but this does not:

Set-QADUser ttest -objectAttributes @{extensionattribute2="test"}
share|improve this question
    
using dsquery with dsmod probably is a little more fullproof. –  tony roth Sep 22 '11 at 19:59
add comment

1 Answer

up vote 2 down vote accepted

Check the actual name of the attribute in Active Directory. The "office" attribute doesn't exist. I believe you want physicalDeliveryOfficeName. Be sure to -IncludeAllProperties when querying a user object to get the extensionAttribute2.

Use ADSIEdit to get a list of AD user properties.

share|improve this answer
    
Strange... I tried physicaldeliveryofficename (incorrect case but correct property) and that worked. I guess "Office" is a property that Quest adds to the object after the fact. extensionattribute2 works also (but you have to use -includeallproperties switch to see it when you query the user object). Thanks. –  Keith Sep 22 '11 at 21:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.