Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not what you would call a network engineer by any stretch, but I was given a 2948G-L3 switch to use. I'd love to add it to the network, but can't figure out a config that will let it do plain L2 switching. I've googled all sorts of configs but nothing seems to work.

Thanks,

share|improve this question
1  
What's the config look like now? –  Shane Madden Sep 22 '11 at 19:41
    
Same type of questioned was asked here supportforums.cisco.com/thread/2052490 the last 2 post may hold your answer. –  Adam Sep 22 '11 at 19:53

5 Answers 5

up vote 1 down vote accepted

It can be done by creating a BVI (bridge virtual interface) and then assigning the ports you want to switch to the BVI. The BVI still must be assigned an IP address, but if you didn't do that, you couldn't manage the switch.

The relevant system-level commands are:

bridge irb
bridge 1 protocol ieee
bridge 1 route ip

To create the BVI:

interface bvi 1
ip address ...

To add an interface to the BVI:

interface ...
bridge-group 1

See this link for information about disabling spanning tree and enabling portfast. You may need portfast to get DHCP/PXE to work in some cases.

Note that the I make no promises about what kind of performance you'll get with this configuration. This is just not what this device was built to do.

share|improve this answer

Your only option on this device would be bridging. It is not a true L2 switch and can never be one.

share|improve this answer

By default, L3 switches only switch out of the box, they don't route out of the box. My suggestion would be to reset the switch to factory defaults and then configure (or not) it accordingly.

share|improve this answer
1  
This is not a standard switch it is more router than switch. –  Adam Sep 22 '11 at 19:58
    
Thanks Adam, I would have never known that. I assumed (wrongly) that this model was like (almost) every other L3 switch. –  joeqwerty Sep 24 '11 at 0:48

Admittedly I've never meddled with a 2948 but usually on the other L3 switches it is simply a case of shutting down the routing engine:

Router(config)# no ip routing
share|improve this answer

Not sure if this will be working on a 2948-L3, but you could try to do the following:

interface FastEthernet0/0
 switchport

If this doesn't work, try to make a bridge-group as David's answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.