Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set-up a virtual host configuration so that

  • requests that go to /cgi-bin/iipsrv.fci are processed by fastcgi
  • all other requests are processed by a proxy configuration

So far tough, I have no clue how to achieve this -- i.e. how to write a rule that matches my virtual host, but not the /cgi/bin/* route.

Any ideas?

share|improve this question

Try this:

$HTTP[url] = "^/cgi-bin/iipsrv.fci" {
    fastcgi.server = ( "/cgi-bin" =>
                       ( "localhost" =>
                          (
                            "socket"   => "/tmp/php" + PID + ".socket",
                            "bin-path" => "/usr/bin/php-cgi"
                          )
                       )
                     )

    }
$HTTP[url] != "^/cgi-bin/iipsrv.fci" {
    proxy.server = ( "..." =>
                     ( "localhost" =>
                       (
                         "host" => "192.168.0.101",
                         "port" => 80
                        )
                      )
                    )
    }
share|improve this answer
    
This does not seem to be working - when I enable this kind of configuration, nothing is accessible anymore. – Manuel Bernhardt Oct 4 '11 at 8:31
    
What does it say? Did you take a look at error log? – quanta Oct 4 '11 at 8:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.