Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

server :
Plesk panel 10.3.1,
PHP 5,
Apache2

When I updated the plesk panel, I noticed a strange error while uploading files. My server does not allow any file to be uploaded above the 128kb, even when the settings in /etc/php5/apache2/php.ini are set to higher sizes.

my settings:

upload_max_filesize = 10M,
post_max_size = 8M,
memory_limit = 128M

The error is really not clear. In drupal this is returned: http error 0 (when uploading I receive a 500 internal server error)

share|improve this question

migrated from superuser.com Sep 23 '11 at 13:56

This question came from our site for computer enthusiasts and power users.

add comment

4 Answers

up vote 5 down vote accepted

Solution:

FcgidMaxRequestLen -->This is causing the problem. Before updating to the newest version, it was default set to 1gb. Now it is 128kb. Add the following to the file /etc/apache2/conf.d/fcgid.conf :

FcgidMaxRequestLen 1073741824

This wil give you a limit of 1gb. Next, restart your apache.

share|improve this answer
    
Mate this saved me on my new ubuntu 10.04 on linode –  benpalmer Feb 3 '13 at 16:56
add comment

In addition to PHP the reason can also be Apache if it has MaxRequestBodySize set or modules like mod_security are in use.

share|improve this answer
add comment

On Plesk that's generally not the default path for php.ini. From the command prompt what do you get when you input:

# whereis php.ini

Mine is located at /etc/php.ini

The 500 error is a 'catch-all' error indicating most likely that something is mis-configured either on the webpage you're trying to access or on the webserver itself. If the error is only on that one page then chances are it's the culprit. Are the permissions set correctly to allow uploads (chmod 755 or 777)?

[Drupal] > See Technotes

enter image description here

share|improve this answer
    
when i upload a smaller file like 50kb, it just saves it on the server. When i type whereis then i receive this:/usr/bin/php /usr/lib/php /usr/share/php /usr/share/man/man1/php.1.gz –  Germaike Sep 23 '11 at 14:04
    
Is there a php.ini in /usr/share/php? –  l'L'l Sep 23 '11 at 14:15
    
no, i also did a sysinfo with php and found out he uses /etc/php5/cgi/php.ini but we have the same settings in this file. any other ideas? the other php.ini's are not filled or not in the dir. –  Germaike Sep 23 '11 at 14:37
    
The error you described also could mean that your Drupal is not configured correctly. Check the settings on that and refer to the image above for reference. Also try what Janne has suggested ~ –  l'L'l Sep 23 '11 at 15:02
    
These fields are empty and set to the default php setting by drupal. I will try out janne his anwser. Thx in advance for all the help. –  Germaike Sep 23 '11 at 20:56
add comment

In CentOS6/PLESK, my fcgid.conf was located /etc/httpd/conf.d/fcgid.conf but solution above worked perfectly, after restarting Apache, of course.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.