Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to transfer files to a server using remote desktop local resources features. For some reason local disks are not shown in explorer on remote server even though I checked "disks" on Remote desktop local resources config tab. On remote server explorer I can see two broken icons in "Other" section with type "System folder" but when I click those icons nothing happens.

I Checked also remote server's Terminal services configuration and local resouces linking are allowed for TS sessions. So what's wrong here?

share|improve this question
    
Check the version of the client you are using. –  MathewC Jun 25 '09 at 12:45
    
Connecting to the same server right? And if you log on to your system as another user? –  MathewC Jun 25 '09 at 19:50
add comment

5 Answers

When I connect from my work machines which runs XP to my home machine that runs Vista 64, my local folder opens and immediately closes. If I open it again, it works fine. This happens every time. I don't know if you have a similar quirk, but I thought I throw it out there.

share|improve this answer
add comment

The only really reliable way to copy files over RDP that I have relied on, almost every time is using the \tsclient\c (or whatever drive you want) method. It does not work in a CMD window, but it works in an explorer window. To use it in a CMD session or script, launch it inside FAR manager or something similar.

It is convenient to use it like this:

start>run
\\tsclient\c

and a window with the local machines files will open.

share|improve this answer
    
+1, my drives were not available in explorer, but your command worked, thanks! –  JL. Nov 3 '09 at 11:12
add comment

It's a long shot but... Run a disk check on your laptop. I've seen some odd behavior occur when there are file system errors, even if they don't otherwise make themselves obvious. It should only take a few minutes to run and certainly won't do any harm.

share|improve this answer
add comment

You say "local resouces linking are allowed for TS sessions". Just to check, you do mean in Terminal Services Configuration, in the RDP-Tcp connection properties, on the "Client Settings" tab the "Drive mapping" tick box is unticked?

JR

share|improve this answer
    
This works for my colleague so RDP-Tcp connection properties should be ok, this problem is somehow related to my laptop/account or something like that. –  Janne Jun 25 '09 at 19:23
    
Get you colleague to TS from your laptop. If the drives don't connect it's your laptop, if they do it's your account. It's possible to disable drive connection in the Active Directory user properties (on the Environment tab of the user properties). –  John Rennie Jun 26 '09 at 6:52
add comment

What OS's are the client / server machines?

One thing to think about, although I am not sure if it affects it or not, is does the account you log into your terminal server session, have access to the local disks on the client machine? I am sure a year or two ago that was an issue for us.

Also this can bork when the machines are on different networks??

share|improve this answer
    
Client is Windows XP and server is windows server 2003. This works for my colleague who also has windows xp and is in same network so it must be somehow related to my laptop. –  Janne Jun 25 '09 at 19:22
add comment

protected by Chris S Oct 4 '11 at 14:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?