Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The server is serving large file very slow, and get very very slow or get stucked when the file is over 150kb.

I've checked everything, the traffic is normal, and if I download the same over FTP, it's fast as normal. (to discard NIC card problem)

Maybe it's a hosting provider problem, but want to clear all other options before calling.

How can I solve or troubleshoot the problem?

share|improve this question

2 Answers 2

In my experience, the behaviour you describe is normally caused by problems with Path MTU Discovery - in particular, by a network which blocks ICMP packets. It's possible that your FTP transfer is staying below the MTU limit, while your HTTP transfer is going above the MTU limit with packets being silently dropped.

To troubleshoot, you should collect more data points and update your question. In particular, try downloading via HTTP from the local machine itself, from a machine on the same subnet, and from a machine on the broader internet. If it's a Path MTU Discovery issue, only the latter will have any problems.

share|improve this answer
    
From the local machine: not a problem. Can't test with a machine in the same subnet –  Eduardo Molteni Sep 26 '11 at 12:12
    
If the download from the local machine is fine, it sounds like a network problem. You'll probably need to ask your hosting provider for help. –  Tom Shaw Sep 26 '11 at 13:43
    
As expected, the hosting company told me: it's not our fault. In the subnet the download was good. So now I have to get data from different providers to show them... –  Eduardo Molteni Sep 26 '11 at 17:03
    
Thanks for the update. As per my original answer, this is consistent with a Path MTU Discovery issue. You should make sure ICMP packets are not blocked by your hosting provider or by your own network. –  Tom Shaw Sep 27 '11 at 0:26
    
Any pointers how to do that? (I'm not a full time sysadmin, just wearing that hat this morning) –  Eduardo Molteni Sep 27 '11 at 12:01

A packet capture and network analyzer might shed more light, but I wouldn't spend too much time troubleshooting yourself when your webhosting package probably offer some kind of support. At least open a ticket with them before you troubleshoot to get the ball rolling. Possibilities can be further eliminated by trying from another machine, trying from outside your edge router, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.