Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I used useradd to create a user called oracle

After that I used su oracle i get in terminal just a $

Do you know why the terminal is not something like oracle@laptophp:~$ and is just a $ ?

share|improve this question
    
Curious. What distribution are you running on? –  Rilindo Sep 24 '11 at 18:37
    
i use ubuntu 11.04 –  Cris Sep 25 '11 at 7:59

3 Answers 3

up vote 4 down vote accepted

You probably did not create your new user with useradd -m. The -m copies the default ("skeleton") shell profile files from /etc to new users home dir.

To resolve the issue, recreate the account or just copy the .bashrc, .bash_profile and .profile files from some other user account or from /etc/profile/.

share|improve this answer

You might also take a look at PS1 environment variable. If you type export PS1="$ ", your prompt will be just a dollar sign.

share|improve this answer

I have been having the exact same problem. Turns out there is an alternative to "useradd" called "adduser". This automatically copies the skeleton and everything needed.

adduser <username>

This code prompts you to fill in information about the user, and copies everything needed (as well as setting up a user directory).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.