Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

hoping someone can help me with a problem here. I'm attempting to setup a test (loan from Cisco) wireless network. Here's what i've got/done:

5508 Controller -
Service Port IP set to 10.74.5.2 /24.
Management IP set to 10.74.6.2 /24 with a default gateway of 10.74.6.1.
Virtual IP set to 1.1.1.1.

Copper SFP in slot 7, CAT5 (known good) going from there to port 1/0/47 on the switch. Green lights on both ends.

2960-S Switch -
Vlan1 - 10.74.6.1 /24.
dhcp pool 10.74.6.0 /24, default router 10.74.6.1.
excluded-address 10.74.6.1, 10.74.6.2.

1/0/4 on the switch is set to switchport mode access and no shut.
1/0/47 on the switch is setup to switchport mode trunk and no shut.
1/0/4 has a CAT5 (known good) cable going from there to the AP.

When I do a sh cdp nei from the switch, i can see the AP and Controller listed.
When i configure my PC's nic to 10.74.5.5, and plug a cable from my nic to the SP port on the controller i can get on the device via the gui. In there, the only errors/info that show up in the trap are:

Link Up: Slot: 0 Port: 7
Controller time base status - Controller is out of sync with the central timebase.

I've manually set the time but apparently that's not quite the problem (or at least not the entire problem).

When i plug the AP in, i see on the switch console that it grants it power, it sees it connect...but the controller won't see it for some reason. From what i've read you shouldn't have to do anything to the AP as it's managed by the controller...but i'm not sure what setting I'm missing for it to work. The AP light on top is continually cycling green, red, yellow. When I first start it up, it blinks green for 20 or so seconds, then goes to solid green for another 20 seconds or so, then flashes blue, green, red for awhile...but always ends up goinn back to the standard, green, red, yellow. Does anyone see any obvious issues with my setup or have any suggestions as to why i might be having a problem? Thanks for your help!

share|improve this question

3 Answers 3

What you've written suggests that it's a VLAN-type issue - on the management interface on the WLC, where you've configured your IP address 10.74.6.2, have you set the VLAN ID to 1?

Out of habit, I'd use a VLAN other than 1 - I try to use VLAN1 as little as possible. My first thought is that the VLAN tagging isn't matching between the AP and the controller.. the management interface will need the VLAN ID (in this case 1), and make sure that you have switchport access vlan 1 on the port connected to the WAP, on top of making sure it's an access port, which you've already done. Failing that, you can make the port the AP is plugged into a trunk port, but you would need to configure the native vlan to match the ID of the management network that the WLC is running on.

share|improve this answer

You need to supply a DHCP option to the AP that tells it to which controller to talk.
Alternative is a special DNS entry for the controller, which the AP will look for. (I can't remember the exact details. I did this some months ago at the office, but I'm on holiday now. No access to the company network.)

If I remember correctly, if there is no info supplied to the AP, it will assume the DHCP server is the controller, which in your case is not true.

share|improve this answer

In the absence of DHCP opt as mentioned above you need to create a DNS A record for a specific host which points to the WLC IP:

CISCO-LWAPP-CONTROLLER such as CISCO-LWAPP-CONTROLLER.mydomain.com

Of course Cisco only publishes half the story; the other half is that other APs use different DNS A record to locate the WLC and that is CISCO-CAPWAP-CONTROLLER

So I had to ad both records in order for all various models of APs to find the controller

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.