Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Windows Server 2003 x64 I had a drive volume become temporarily unavailable (an external iscsi storage device). In the course of troubleshooting I rebooted the machine, and the external volume did become available again until after the reboot. Now the shares I had pointing to the external volume are no longer available. The registry shows the missing shares and their permissions. How do I get them back?

I would like to avoid recreating them as new shares as it will be some work to apply the various permission levels to each.

This is what "Computer Management > Shared Folders" shows now (system shares omitted):

Maps   E:\maps
Work   E:\Work

and it should be:

Maps   E:\Allofit\maps
Work   E:\Allofit\Work
Archives  G:\Archives
Warehouse G:\Warehouse

And here are the registry entries for the missing shares (hex values omitted):

share|improve this question
Here's cure to the problem behind the problem: Windows Server 2003 forgets folder shares from ISCSI-Volume after restart – matt wilkie Oct 9 '12 at 21:28
up vote 1 down vote accepted

Turns out the solution was as easy as it is annoying: reboot the server 1 more time, then the old shares are available again.

I speculate that I could have acheived the same result by restarting one or some of the network services, and I considered doing that, but since this is a headless box and all the managment is done from remote was safer to reboot, though I did need to run around and get people to close their active files first.

share|improve this answer

there's a more simple solution for that: restart the server service.

c:\> net stop server
c:\> net start server

sometimes other services depend on the lanman server service; they will automatically be restarted in this case.

share|improve this answer
Welcome to server fault! HTML generally gets filtered out; we use markdown instead. Check out the help link by the search box. I've edited the correct formatting in for you. – Falcon Momot Jan 13 '14 at 3:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.