Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Cacti + RRDTools yesterday via yum on CentOS 5. Everything appears to have installed correctly and the cacti directory is located /var/www/cacti. I setup a sub domain to point to it.

However, my issue is that I always get a 403 Forbidden error when trying to access any of the files. There is no Apache HTTP Auth on the directory. I've changed the ownership and group of the files from root to cactiuser (my cacti user), to apache, to nobody and nothing solves this.

I've also tried accessing it from the machine itself (localhost) and still get the 403.

Has anyone had these issues? I can share more details about the config if you like.

it appears to be something with the server config... here's the log

[Thu Jun 25 10:04:57 2009] [error] [client 10.1.10.10] client denied by server configuration: /var/www/cacti/index.php
[Thu Jun 25 11:48:17 2009] [error] [client 10.1.10.10] client denied by server configuration: /var/www/cacti/debug.html
share|improve this question
    
Does your vhost serve static HTML pages fine? i.e. If you create /var/www/cacti/debug.html and try to access it via your http://{vhost_name}/debug.html does it display properly? –  StackKrish Jun 25 '09 at 15:02
    
What's in the error_log? –  freiheit Jun 25 '09 at 15:11
    
doesn't serve static files either (also php works on the server at other virtual hosts so i don't think that's the issue). –  nategood Jun 25 '09 at 15:50

2 Answers 2

up vote 0 down vote accepted

I just installed Cacti on Cent this morning, according to the documentation I used, cacti should be installed in /var/www/html/cacti, may be a different version.

http://www.cacti.net/downloads/docs/html/unix_configure_cacti.html

Try changing this in your apache cfg, some versions of Cacti it may be cacti.conf AllowOverride None Order Deny,Allow

to

AllowOverride None Order Deny,Allow Deny from all

Something else, it still could be a permissions error, that's where I had the most issues. Try adding apache and cactiuser to the same group and change your permissions according.

You will need to restart apache /etc/init.d/httpd restart

share|improve this answer
    
thanks. didn't notice the cacti.conf in the apache conf.d dir. that solved it. –  nategood Jun 26 '09 at 4:08

Do you have Selinux enabled ?

If yes check the label of the file in /var/www/cacti.

But the RPM should have taken care of it, I guess...

share|improve this answer
    
SELINUX=disabled SELINUXTYPE=targeted –  nategood Jun 25 '09 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.