Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am going a little crazy trying to get Samba working and would really appreciate some pointers. It's quite possible that I have misconfiged some part of the network configuration too.

I am running Ubuntu 11.04 Server. smbd reports version 3.5.8.

My server has two network interfaces configured. One is the primary interface I usually use (eth0), and there is another which will only be used for samba (eth3).

I can always get to the server via eth0, and it works perfectly. However, eth3 just refuses to work. I've experimented with these settings in smbd.conf:

interfaces = eth3
bind interfaces only = yes

But eth3 still does not work. Any ideas?


More information:

  • I can ping eth3
  • I can ssh into eth3
  • iptables is down
  • I can run nmap against eth3 and it reports Samba is listening (so I don't think a switch is blocking ports)
  • I've set samba logging to log level 3, but cannot see anything interesting in the samba logs (so maybe its not a samba problem...?)
  • nmbd is not running (I don't need it if I'm connecting via the servers IP, right?)
  • output of netstat -tapn | grep smbd
tcp 0 0 192.168.0.3:445 0.0.0.0:* LISTEN 1843/smbd
tcp 0 0 192.168.0.3:139 0.0.0.0:* LISTEN 1843/smbd
tcp6 0 0 fe80::b699:baff:feb:445 :::* LISTEN 1843/smbd
tcp6 0 0 fe80::b699:baff:feb:139 :::* LISTEN 1843/smbd
share|improve this question

1 Answer 1

Figured it out:

On the windows machine, the network card which was connecting to eth0 has "Client for Microsoft Networks" enabled.

The network card which was connecting to eth3 had it disabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.