Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using SQL Server 2005.

I set up a new user on my development SQL Server, and made him an owner on a specific database. I can log in as him, see all the databases, and open only the database specified.

I set up the user on my production SQL Server using the same exact procedure (set as owner on a specific database), but when I log in as him I cannot see any databases listed. What can I do to fix this?

share|improve this question
up vote 1 down vote accepted

If your using SQL Server 2005 tools aka SSMS (SQL Server Management Studio). Make sure you install SQL Server 2005 SP3. Even if you don't have the SQL Server Services / DB Engine running this has a number of bug fixes and upgrades for the SSMS tools.

SQL Server 2005 SP3

share|improve this answer

Right click and refresh on database folder? Sometimes SSMS gets weird refreshing data. Also make sure his login account is under Security folder and mapped to the specific database. Are both dev and prod at same SP level?

share|improve this answer
Everything looks good. How can I tell the SP level of the two environments? They're probably not the same. – Mike Cole Jun 25 '09 at 14:40
Connect to both instances in your SSMS. After the server name you'll see (SQL Server 9.0.xxxx). The last four numbers let you know what revision level they're at. 2005 Build list: 2008 Build list: – SQLChicken Jun 25 '09 at 14:58

If your production server is 2008 you may run into an issue. I answered a similar sounding question on stackoverflow.

click View, Object Explorer Details. Then, open Databases. Finally, click the header columns and uncheck Collation.


I solved this for my own machine a while ago and had to look the issue back up. Hopefully this link and the links from there will help you find the answer if this doesn't. It seems familiar to what i had to do.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.