Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am logged onto my Windows Server 2003. I am trying to ping another server that is Windows 2008 by using the command promt and putting in the ip address that I had given it. For some reason it seems to be timing out every time I ping it. If I try to connect to it using mstsc and the ip address it will allow me to join it. For some reason though when I use netscan it doesnt appear or if I try to ping it.

Why would this happen and how can I enable ping on my server?

share|improve this question
2  
icmp is being blocked somewhere most likey the firewall on the w2k8 server is on and the firewall is allowing connectivity to 3389. –  tony roth Sep 27 '11 at 14:18
    
don't think I'd disable it I just set it to allow ICMP. –  tony roth Sep 27 '11 at 14:22
    
how do i go about doing this? –  ben950 Sep 27 '11 at 14:25
add comment

2 Answers

up vote 3 down vote accepted

On the 2008 server, allow 'File & Print Sharing' in the firewall. Then, ping will start working as expected. This will also enable file & print sharing, so you might not want to do this. In the firewall there may be a way to just allow ICMP Ping, but not file sharing.

share|improve this answer
    
Thanks that has seemed to work. also how do i accept 2 answers on this site –  ben950 Sep 27 '11 at 14:35
1  
You can only choose one answer. I tend to pick the one that will be most helpful to someone who might come across this page when they themselves are trying to resolve a similar problem. You may upvote more than one answer and should do so if they were of assistance to you. –  pk. Sep 27 '11 at 14:54
add comment

A ping uses the ICMP protocol which is different from the TCP/IP and UDP protocols almost every other service uses. The inability to get a ping response from a server but still being able to connect to it using a TCP/IP connection is totally normal. Obviously, your server is set to not to respond to ICMP requests. If you want to be able to ping it, you'll have to change that setting to allow it to respond to ICMP requests.

share|improve this answer
    
Thank i didnt no that. How do i turn on ICMP? –  ben950 Sep 27 '11 at 14:23
1  
I'm a Linux guy, not a Windows guy so I can't vouch for this method, but it looks like this will work for you. At the command prompt in your 2008 server, type : netsh firewall set icmpsetting 8. I got this from this article which seems to address what you need: petri.co.il/enable-ping-windows-2008-server.htm –  jdw Sep 27 '11 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.