Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to connect to a remote computer. but on m side i believe that my SonicWall Firewall is blocking me from sending a request out. I do not know how to configure the firewall to allow access for RDP on a non standard RDP Port. I have tried adding in the Firewall - "Services" Section, but no luck. SonicWall Model "TZ 190 Wireless Enhanced". updated settings

share|improve this question

3 Answers 3

Create a new service for the ports that you are using.

Then Click Firewall > Access Rules tab. Select the type of view in the View Style section and go to WAN to LAN access rules. Click Add a new entry and create the rule by entering the following into the fields:

Action: Allow From Zone: LAN To Zone: WAN Service: MY CUSTOM SERVICE Source: Any Destination: ANY Users Allowed: All Schedule: Always on Enable Logging: checked Allow Fragmented Packets: checked

share|improve this answer
    
I tried your solution I thought it would work but it didn't. is there a way to trace where it gets blocked? –  greektreat Sep 27 '11 at 18:32
    
Follow Miles Erickson's post about the packet capture feature. –  Christopher Karel Sep 28 '11 at 21:37

You will need to take advantage of the Sonicwall's "Packet Capture" feature. When you set up the capture, set the source IP to your computer's private IP address and the TCP port to 3389. Start the capture, then attempt to make an outbound RDP connection. Refresh your view of the packet capture and it will tell you what the Sonicwall did with the packets in question.

share|improve this answer

That answer is a little confusing, you said to go to firewall rules WAN->LAN, but then add a rule LAN->WAN.

If you are unfamiliar with setting the firewall rules, the easiest method is to just use the public server wizard. The server type will be set to other, then choose the custom service for your RDP port. Server IP will be set to private IP address of RDP computer. Public IP is your public IP...and voila it makes all the rules for you.

I'm pretty sure it defaults the rules to allowing anyone to access that non-standard RDP port, so you change the firewall rule to only allow admins or whatever.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.